Author Topic: Using Chilkat with Bundler  (Read 411 times)

Chilkat

  • Administrator
  • Jr. Member
  • *****
  • Posts: 90
  • Karma: +4/-0
    • View Profile
Using Chilkat with Bundler
« on: November 17, 2017, 09:45:52 AM »
Specifically, I can use the Ruby 2.0 version for Mac (it works very well), but when I try to do a 'bundle install' with the 1.9.3 64-bit version for Linux, Bundler complains that we need Ruby 2.4.

We deploy this (older) app on Centos using Ruby 1.9.3, and moving the app to a newer version of Ruby would be quite painful.

Am I doing something wrong with the 1.9.3 version?

Chilkat

  • Administrator
  • Jr. Member
  • *****
  • Posts: 90
  • Karma: +4/-0
    • View Profile
Re: Using Chilkat with Bundler
« Reply #1 on: November 17, 2017, 09:46:46 AM »
We are putting the  9.5.0.69 version into vendor/cache and forcing bundler to use it via the line

gem 'chilkat', '=9.5.0.69'

in ./Gemfile.

Then, we are getting the following error:

Bundler could not find compatible versions for gem "ruby":
  In Gemfile:
    ruby

    chilkat (= 9.5.0.69) was resolved to 9.5.0.69, which depends on
      ruby (~> 2.4)

Chilkat

  • Administrator
  • Jr. Member
  • *****
  • Posts: 90
  • Karma: +4/-0
    • View Profile
Re: Using Chilkat with Bundler
« Reply #2 on: November 17, 2017, 09:47:20 AM »
Ah, I finally put the following in the Gemfile:

gem 'chilkat', '=9.5.0.69', :path => "vendor/cache"

and that did the trick.  Funny, I always thought that Bundler looks in vendor/cache by default, but apparently not.