Author Topic: Amazon SES SMTP just stopped working over the weekend  (Read 552 times)

echodreamz

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Amazon SES SMTP just stopped working over the weekend
« on: December 04, 2017, 03:41:23 PM »
No changes occurred on our end, but it is now returning that our credentials are wrong, however they are not.

Code: [Select]
220 email-smtp.amazonaws.com ESMTP SimpleEmailService-2638130967 DglLx6sFLLTHXvJWc4i0
EHLO WSP
250-email-smtp.amazonaws.com
250-8BITMIME
250-SIZE 10485760
250-STARTTLS
250-AUTH PLAIN LOGIN
250 Ok
AUTH LOGIN
530 Must issue a STARTTLS command first
EHLO {REMOVED}
250-email-smtp.amazonaws.com
250-8BITMIME
250-SIZE 10485760
250-STARTTLS
250-AUTH PLAIN LOGIN
250 Ok
STARTTLS
220 Ready to start TLS
EHLO {REMOVED}
250-email-smtp.amazonaws.com
250-8BITMIME
250-SIZE 10485760
250-STARTTLS
250-AUTH PLAIN LOGIN
250 Ok
AUTH LOGIN
334 VXNlcm5hbWU6
{REMOVED}
334 UGFzc3dvcmQ6
{PasswordOrCredentials}
535 Authentication Credentials Invalid
QUIT
221 Bye

Code: [Select]
ChilkatLog:
CloseSmtpConnection:
DllDate: Nov 27 2017
ChilkatVersion: 9.5.0.70
UnlockPrefix: *MAILQ
Architecture: Little Endian; 64-bit
Language: .NET 4.6 VS2017 / x64
VerboseLogging: 0
sendCmdToSmtp:
SmtpCmdSent: QUIT
--sendCmdToSmtp
readSmtpResponse:
SmtpCmdResp: 221 Bye
--readSmtpResponse
--CloseSmtpConnection
--ChilkatLog

I checked the SMTP username being sent (according to the session log) and the username (per the base64 decode) is correct. However the password I cannot verify as it is not in the logs. However I've made sure they are correct in the settings. Our billing system (PHP-based), using the same credentials has no issues. Changed over to another library and emails send without issues.

Using Chilkat 9.5.0.70. (.net).

Any help would be awesome! Thanks!
« Last Edit: December 04, 2017, 03:48:53 PM by echodreamz »